Puppeteer在win2008 R2下的坑

原文地址: Puppeteer在win2008 R2下的坑

不要使用默认的 Windows 命令处理程序(CMD.exe)

使用PowerShell或第三方命令行工具来执行Puppeteer,例如Git自带的git bash。

在cmd下执行各种报错,启动Chromium页面直接崩溃。。。

在win2008下跑Puppeteer不但速度慢而且只能跑单线程

明明在win7下跑得好好的,同样的代码同样的配置在win2008下跑多线程竟变单线程,而且运行速度相对较慢,初步判断应该跟Chromium在win2008下的运行有关,google发现还真有人遇到类似情况,估计应该与win2008默认的网络安全配置有关,解决方法也简单,添加两行参数即可。

const browser = await puppeteer.launch({
    args: [
        "--proxy-server='direct://'", 
        '--proxy-bypass-list=*',
    ]
})
我来评几句
登录后评论

已发表评论数()

相关站点

热门文章