PHP 7.3 “continue” targeting switch is equivalent to “break”. Did you mean to use “continue 2”?

Composer PHP7.3 SHA384 is not supported by your openssl extension

在使用composer 更新时候的,报错

解决方法

composer selfupdate

composer self-update

再次报错如下:

SHA384 is not supported by your openssl extension, could not verify the phar file integrity

解决(mac)

重新下载在安装

rm -f /usr/local/bin/composer

curl -s https://getcomposer.org/installer | php

mv composer.phar /usr/local/bin/composer

Remove Your older versions and install the latest version of Composer,

Remove Your older version: sudo rm -f /usr/local/bin/composer

Download the installer: sudo curl -s https://getcomposer.org/installer | php

Move the composer.phar file: sudo mv composer.phar /usr/local/bin/composer

参考:

https://www.heibaiketang.com/forum/show/173.html

我来评几句
登录后评论

已发表评论数()

相关站点

+订阅
热门文章