PandoraBox 负载均衡配置

知识科普

单线多拨就是让用户在只有一个宽带账号的情况下,在路由器上同时多次拨号,可以将带宽翻倍。打个比方,比如我这里是的50M电信光纤,如果在路由器上双拨成功,那么带宽就变成100M,如果三拨成功,带宽就变成150M,并且无需付出任何额外开销。

战前准备

  1. 搭载PandoraBox系统的路由器(我这里是小米Mini版)
  2. 充满智慧的大脑

注意:某些地区的宽带运营商限制了多拨,还有些地区即便是可以多拨,但是宽带不叠加。

战斗开始

1.首先登录PandoraBox系统

2.进入 网络——负载均衡——高级 选择 网络配置文件  ,找到类似下面代码

config interface 'wan'
 option ifname 'eth0.2'              #这里是网卡名(大家的网卡)
 option _orig_ifname 'eth0.2'
 option _orig_bridge 'false'
 option macaddr '00:00:00:ff:ff:ff'  #这里是宽带运营商绑定的MAC地址
 option proto 'pppoe'                #这里是宽带连接方式
 option username 'username'          #这里是宽带账号
 option password 'password'          #这里是宽带密码

3.在其下方添加虚拟网卡wan2的信息(需要自行修改,其他代码保持不变),代码如下

config interface 'wan2'
 option ifname 'eth0.2'              #这里是网卡名,与wan值相同
 option proto 'pppoe'                #这里是宽带连接方式,与wan值相同
 option username 'username'          #这里是宽带账号,与wan值相同
 option password 'password'          #这里是宽带密码,与wan值相同
 option metric '20'                  #这里是网卡跃点数(默认wan中需要自行添加且数值与wan2不同)

修改之后的代码

config interface 'wan'
 option ifname 'eth0.2'
 option _orig_ifname 'eth0.2'
 option _orig_bridge 'false'
 option macaddr '00:00:00:ff:ff:ff'
 option proto 'pppoe'
 option username 'username'
 option password 'password'
 option metric '10'
 
config interface 'wan2'
 option ifname 'eth0.2'
 option proto 'pppoe'
 option username 'username'
 option password 'password'
 option metric '20'

4.进入 网络——负载均衡——高级 选择 MWAN配置文件  ,将原代码全部替换为下面的代码

config interface 'wan'
 option enabled '1'
 option reliability '1'
 option count '1'
 option timeout '3'
 option interval '8'
 option down '8'
 option up '8'
 option reroute '1'
 list track_ip '223.5.5.5'
 
config interface 'wan2'
 option enabled '1'
 option reliability '1'
 option count '1'
 option timeout '3'
 option interval '8'
 option down '8'
 option up '8'
 option reroute '1'
 list track_ip '223.5.5.5'
 
config member 'wan_m1_w1'
 option interface 'wan'
 option metric '1'
 option weight '1'
 
config member 'wan2_m1_w1'
 option interface 'wan2'
 option metric '1'
 option weight '1'
 
config policy 'wan_only'
 list use_member 'wan_m1_w1'
 
config policy 'wan2_only'
 list use_member 'wan2_m1_w1'
 
config policy 'vtrois_rule'
 list use_member 'wan_m1_w1'
 list use_member 'wan2_m1_w1'
 
config rule 'rule2'
 option proto 'tcp'
 option use_policy 'wan_only'
 option dest_port '443'
 
config rule 'rule6'
 option use_policy 'vtrois_rule'
 option proto 'all'

5.重启路由,届时就会看到 网络——接口 中会多一个WAN2出来,接下来分别点击WAN和WAN2的  连接  按钮

6.再回到 网络——负载均衡——总览 中会发现MWAN负载均衡的接口状态均为绿色即说明配置成功

我来评几句
登录后评论

已发表评论数()