【漏洞通告】Apache Solr Velocity远程代码执行漏洞

1.综述

Apache Solr是美国阿帕奇(Apache)软件基金会的一款基于Lucene(一款全文搜索引擎)的搜索服务器。该产品支持层面搜索、垂直搜索、高亮显示搜索结果等。

近日,国外安全研究员s00py公开了一个Apache Solr Velocity的利用方式,攻击者可通过Velocity模板实现远程代码执行。该漏洞在”params.resource.loader.enabled”设置为true时,通过精心构造,发送相应的 GET 请求,导致远程代码执行漏洞。目前该漏洞利用详情已经广泛流传于Github以及各大安全群,且公开的EXP可以执行任意命令并自带回显。

2.漏洞概述

漏洞类型:远程代码执行漏洞

危险等级: 高危

受影响系统:Apache Solr <=8.2.0

3.漏洞描述

Apache Solr的Velocity模板存在远程代码执行漏洞。该漏洞在”params.resource.loader.enabled”设置为true时,通过精心构造,发送相应的 GET 请求,导致远程代码执行漏洞。目前该漏洞利用详情已经广泛流传于Github以及各大安全群,且公开的EXP可以执行任意命令并自带回显。

4.修复建议

1).目前官网暂未发布更新,请随时关注官方进展修复该漏洞:http://lucene.apache.org/solr

2).建议通过配置口令或访问控制把后台收入内网来限制对solr的访问。

5. 即时检测

青藤云安全在漏洞爆出的第一时间,已经及时分析响应并支持该漏洞的检测。

具体产品的使用方法:登录青藤主机平台,选择漏洞检测功能进行检查。

参考链接

https://github.com/wyzxxz/Apache_Solr_RCE_via_Velocity_template

我来评几句
登录后评论

已发表评论数()

相关站点

+订阅
热门文章