Firefox 打包太复杂,OpenBSD 稳定版将不再接收其更新

OpenBSD 宣布 ,由于 cbindgen 和 rust 的依赖性,Firefox 太复杂而无法在稳定分支上打包,并且这样做将需要测试所有 rust 使用者。因此 OpenBSD 6.6 稳定版的分支不会收到来自 www/mozilla-firefox 的更新。

Firefox 72 前几天刚刚发布,发布后第二天,Mozilla 就针对严重漏洞  MFSA2020-03 进行了紧急修复,并发布了 Firefox 72.0.1 版本。OpenBSD 6.6 无法接收 Firefox 更新也就意味着用户仍有可能遭受漏洞的攻击。

另一方面,OpenBSD 表示 firefox-esr 仍在正常更新,建议运行 6.6 稳定版的用户切换到 firefox-esr。 Firefox ESR 即延长支持版,是专门为大学或公司等大型机构研发的 Firefox 正式版,它可以帮助这些组织大规模地部署和维护 Firefox。

如果仍在运行 OpenBSD 6.5,还是应先升级到OpenBSD 6.6。该版本于 2019 年 10 月发布,是目前最新的稳定版。

OpenBSD-current 用户则不受影响,www/mozilla-firefox 更新已提交,将很快在镜像上可用。

我来评几句
登录后评论

已发表评论数()

相关站点

+订阅
热门文章